32x32/8 Matrix mapping help

Hi all,
I’m trying to get my 32x32 matrix mapped using the MultiRowRefreshMapping sketch. I am using a teensy 3.6 with a SmartLED hat.
The reason I think my matrix is a 1:8 scan rate is because of a 8s printed on the silk screen on the back.

Attached below is the map I came to, and the movement of the red pixel.

Something I find odd is the pixel moved to 256 spaces rather than the 128 described on the wiki instructions.

For the settings in reverse engineering mode I used
SM_PANELTYPE_HUB75_16ROW_MOD8SCAN , 64 width, 16 height
as described here:

I tried the mapping the above diagram would result in and my images were still jumbled up.

Any help trouble shooting would be much appreciated!


I thought I’d try provide some more information to see if anyone would be able to help:

Based on the drawing above, I used the following pixel map:










which resulted in a matrix looking like this

I also tried reducing the size of the pixel map so it only went up to 127, but that didnt help either

The model number on the back of my board is p6-8s-2727-3232A

I realised I misread row and column for the ‘row off’ column of the pixel map, so my current pixel map looks like this:
const PanelMappingEntry panelMap32x32Mod8[] =








However the same thing happens.
I noticed the jumbled mess of pixels wasn’t there until I unplugged and replugged the teensy from its usb supply.
Another thing I noticed is only 64 red pixels show before swapping to another colour.