64x64 1/16 scan LED matrix not displaying correctly


#1

Hello. Hoping I could get some help with this…bought this LED matrix. I have a Teensy 3.6 with SmartLED Shield v4 and the latest library installed. I’ve uncommented the line to make the v4 shield work. I also changed kmatrixheight and width to 64 and 64.

This is what displays when I ran the ‘Feature Demo’ example sketch:
Lines 1-16 and Lines 33-47 are lit. The other lines are blank. And from what I can gather…what is actually showing on my display is contiguous and is the what should be the bottom half of the ‘Feature Demo.’ For example what I’m seeing on 1-16 should actually be on 33-47 and 33-47 should be on 48-64. I’m basing this on the fact that when I ran the demo set as 32x32 on my 64x64 display I got the full ‘view’ of the demo except it wasn’t contiguous and was mirrored side-by-side to fill up the 64 width. Again only lines 1-16 and 33-47. I hope what I’m describing makes sense I can upload a photo or video if it helps.

Could this be a soldering problem? This was my first time soldering ever. I don’t see anything obviously wrong with it but just throwing it out there.


#2

Hmm the website says 1/16 but I think they are 1/32 based on this on the back of my panel “64x64-32s”


#3

There’s support for that panel in the code on GitHub, but it’s not packaged up into a release yet.

Use this panelType: SMARTMATRIX_HUB75_64ROW_MOD32SCAN

Did you get the SmartLED Shield from SparkFun as well? They just started selling it: https://www.sparkfun.com/products/15046

I’ll have to get support for this panel packaged up into a release.


#4

Yes I got that shield. I found an old thread where someone got it working but couldn’t get it working myself after making all the changes but then I noticed you updated the source and I had downloaded 3.1.0.zip which didn’t have those updates yet! It works now. Thank you so much.