Gif playback issue


#1

Hello! I am using the new Smart Matrix V4 with a Teensy 3.6. Currently, I am still using the Animated Gif sketch from the git repo. I am running into an occasional issue where the custom gif I’ve made is being a bit weird. It’s always on the same gif and it’s happened on big and small gifs (kB wise).
Here is a video of what I’m talking about.

Here is the original gif.poke

Any idea why this is happening?


#2

Hi, I’m not sure exactly what the problem is, but try running your GIF through one the of the tools at ezgif.com (e.g. GIF Optimizer) and see if the new encoded GIF plays correctly.

What tool did you use to create the original GIF?


#3

Thanks! I made the sprite in Aesprite. This issue started when I moved the sprite from the middle to edge. The old gif of the sprite in the middle worked great. Weird.

Anyways, I ran the glitchy gif through the optimizer (coalesce) and it’s working great now. I appreciate it!

I’ve been working on this project for a while, and I’ve used about 4 different microcontrollers (arduino mega, raspberry pi, and a teensy 3.2 that was thrown away on accident). This shield has made the process very easy. Thanks for doing such great work. I’ll upload a video of my graduation hat once I get everything done.


#4

Is there any chance the sprite is outside the bounds of the GIF? This reminds me of another GIF that had issues when a part of the original image was outsides the bounds. I think the software generating the GIF should trim everything to fit within the bounds of the GIF, but maybe the spec allows drawing outside the bounds. The GIF code included in SmartMatrix Library doesn’t handle it though.

Looking forward to seeing your graduation hat!