Idea - SmartMatrix Games


#1

I’ve worked on creating a few games for SmartMatrix in my spare time.

Here are a few older videos. These are all on prototype hardware with paper for a diffuser, instead of acrylic like the final SmartMatrix display hardware.

Pac-Man:

Snake:

Breakout:

I’ve also worked on a Tetris clone, a maze game, and a simple puzzler. I’ll follow up with more details later.

Thoughts? Suggestions? Does playing simple games like this on SmartMatrix appeal to you at all? Any other games you’d like to see?


#2

Hi Jason. This looks great. I was going to try to install 1-pixel Pacman myself after finding it on hackaday.

Could you please allow me access to the files so I can update my PixelMatrix to include the games? I got the prototype version of the PixelMatrix from Kickstarter after it was unsuccessful :(. Louis let me know my version does not use a Teensy chip.


#3

Hi Matthew, I will work on instructions for compiling later today. I just checked and the games are already in the code, but aren’t included by default. Check #define GAMES 0 in Aurora.ino.

I’ll get you more details late this afternoon.


#4

@Matthew_P I added details on compiling. I’m not near any SmartMatrix hardware right now so I can’t try compiling games in. If I get a chance (probably tomorrow), I’ll try compiling and will upload a software.bin file.

http://docs.pixelmatix.com/SmartMatrix/postkick.html#modifying-smartmatrix

Please let me know if there’s anything confusing or missing so I can make sure to update. I’ll proofread again tomorrow with fresh eyes.


#5

Hi @Louis @Jason

I started again from scratch. Deleted all traces of my old folders, etc. Followed instructions given to compile Aurora https://github.com/pixelmatix/aurora/wiki/Compiling

Fresh Arduino 1.6.5 install
Installed Teensyduino 1.23 to Arduino install directory plus,
-DS1307RTC
-IRremote
-Time

Add .zip source Library via Arduino application. They ended up in the sketchbook directory in \Libraries with the following folder names

  • aJson-master
  • FastLED-3.0.3
  • SmartMatrix_32x32

Deleted RobotIRemote from Arduino /libraries folder

Copied Aurora 1.6 source sketch to my sketchbook folder and rename to aurora. The directory then has folder:
Aurora–/
------------- .h files and aurora.ino
-------------Bin (Folder)
-------------sd (Folder)

Libraries–/
---------------aJson-master (Folder)
---------------FastLED-3.0.3 (Folder)
---------------SmartMatrix_32x32 (Folder)

Open Aurora.ino
Change CPU to Teensy 3.1 and CPU to 96MHz optimised overclock
Click Verify

I get the issues below. Any ideas? Thanks :smile:

Error Output

[Click - PasteBin][1]
[1]: http://pastebin.com/cBxaH4kL



#6

Looks like you have FastLED 3.0. You’ll need 3.1 or newer: https://github.com/FastLED/FastLED/tree/FastLED3.1


#8

Thanks @Jason for the link. Am I able to just change #define GAMES 0 to #define GAMES 1 to try out the games?

Hi @Louis. Might need some more details when you have time on the process of “Install srec_cat tool: http://srecord.sourceforge.net/” I have the zip file “srecord-1.64-win32.zip” but it is not an installer. It only provides the applications for command line usage. I assume these need to be put somewhere before going on with the “Modify boards.txt” part of the process?

(Edit, I can only reply 3 times as I am new, so I had to edit this one :frowning: )


#9

No problem, sorry for the trouble. I’ve updated the Compiling page of the Aurora wiki with better instructions on installing FastLED.

Yeah, that will enable Snake and Tetris. There are more games (Pac-Man, Breakout, etc) in the older LightAppliance sketch that I have not yet ported over to Aurora.


#10

Actually, I’m getting errors when trying to build Aurora with games enabled. It builds fine in Arduino, but trying to use srec_cat to combine the USB-MSD and bootloader fails. We’ve packed so much into Aurora, I think we’ve run out of storage space… I’ll see if I can free some up.


#11

You can always leave out the USB-MSD loader. It’s not required for Aurora to function, though if it’s not there using the “Update Files” settings menu item will fail.


#12

Maybe I should change the term “install” regarding srec_cat. You just need to put the executable somewhere you can get to it from the commandline or if you’re setting up Arduino to run srec_cat, it needs to go inside the Arduino package. There are details on where to put it in the instructions, but let me know if it’s unclear.

The 3 post limit seems like it should be lifted if someone replies to your post, like I’m doing right now. Please send me an email or private message me through the forum if it’s not working. I don’t get a notification on edits, so I only saw your edit coincidentally just now.


#13

I will give this a go over the weekend and let you know my results. Just so you know, the Smart Matrix is enjoying the views from Australia :wink: