No gifs directory error

Hi!
Im trying to use animatedgifs.ino scatch. if i upload it as is, it works, althoug it displays incorrectly (twice on height, half time on length - i am using two 32x64 panels that make 32x128). anyway, point being, it loads up.
the moment i change anything in the code, eg cos id like to look it proper, it displays no gifs directory message. now i suspect this is a software problem but i have no clue where exactly it lies.
i tried using different sd libraries, but in vain too. I deleted espressif hardware completely. i tried using built in arduino default and also tried using one that comes with teensyduino. nothing helped.
is there something im missing?
thanks

Try power cycling the ESP32 board after programming. I’ve found that the ESP32 has trouble reading the SD card after a reset, where it doesn’t after a power cycle.

Hey
Thanks for the info. I forgot to mention that im running it on teensy 3.2 so any esp issue is probably irrelevant. That was why i deleted the whole espressif hardware folder from arduino too, just to be sure its not using wrong libraries.
Anyways, would you have any other ideas?
Best
Michal

Sorry, no, I’m out of ideas. I haven’t heard of this before.

Do normal SD Library sketches work with your Teensy and SD card?

Can you change something trivial with the sketch (like the text that’s printed out for debugging) and does that simple of a change also break the sketch?