Teensy 3.5 with vers 3 sm board and Aurora.?


#1

Hey Louis and Jason… Hope you guys are well…

I purchased the Teensy 3.5, with hope that i could attach it to ver 3 smartmatrix board and use the extra memory to run Aurora in 64x64 mode… at this time i can run the gif animations on the 3.5 with no problem. But not Aurora it will not compile without errorrs. Jason had made a few adjustments last year to Aurora for the 64x64 but that did not seem to help. I have the latest arduino ide, and teensyduino… and latest smartmatrix library with latest edits but still i have no luck ?

error as follows…

aJSON.h:92:6: error: conflicting return type specified for ‘virtual int aJsonStream::flush()’

int flush();

  ^

In file included from C:\Program Files (x86)\Arduino\hardware\teensy\avr\cores\teensy3/Stream.h:24:0,

             from C:\Program Files (x86)\Arduino\hardware\teensy\avr\cores\teensy3/HardwareSerial.h:252,

             from C:\Program Files (x86)\Arduino\hardware\teensy\avr\cores\teensy3/WProgram.h:46,

             from C:\Users\Mannys\AppData\Local\Temp\arduino_build_905405\pch\Arduino.h:6:

C:\Program Files (x86)\Arduino\hardware\teensy\avr\cores\teensy3/Print.h:62:15: error: overriding ‘virtual void Print::flush()’

virtual void flush() { }

I Am running a very trimmed down version of aurora with clock feature and about 6 patterns on the teensy 3.2 on a 64x64 setup… 2 x 32x64 panels… would love the help to get it all on the teensy 3.5…


#2

Just to add… All the smartmatrix demos work on the teensy 3.5 just fine. clock, feature demo etc. i did even try the hex file within the Aurora folder on the 3.5 and i got 4 perfect 32x32 Auroras… i have tried compiling the full version for the teensy 3.2, 3.5, and 3.6 and get the same errors


#3

Did you try this branch? I don’t think Jason finished the port on this, he mentioned something about there being a pause between looping GIFs, but it should mostly be working.

https://github.com/pixelmatix/aurora/tree/sm3.1-teensy3.6-64x64

The issue may be with the aJSON library and not Aurora. Maybe they have an updated version of the library available?


#4

Hi Louis I did try that branch and it’s the one I’m having issues with. The last update was about 7 months ago. Jason had also done some work on the gif player to fix some issues. I did share some errors with him in a previous post at the time. I was hoping maybe there had been an update or fix…


#5

Looks like you’re not the only aJSON user to run into this issue. There’s a pull request that fixes it but it looks like the library is not being maintained.

I was able to get past the error when compiling by using this fork of the library, but I’m still getting other issues.


#6

I got it to compile fully, though I haven’t tested it. Jason’s fork of the AnimatedGIFs sketch needs to be put in the Arduino Libraries directory, as Aurora depends on files from the sketch. (I’ve been refactoring AnimatedGIFs so it can be used as a library, though it’s not fully an Arduino Library yet)


#7

The sketch seems to work at least in a limited capacity on a SmartMatrix Shield V4 with 64x64 panel. I see patterns displayed, but I don’t have an IR remote set up to try anything else.

If I add a SD card, it crashes before displaying anything. It will add the “AURORA” and “GIFS” folders and MESSAGES.TXT to a blank SD card. I think the Aurora folder is usually supposed to have some config files inside, but they are missing. This could be a side effect of modifying aJSON, maybe something broke.

I believe Jason is busy, so I wouldn’t expect this to get fixed anytime soon.


#8

I believe this was working back when Jason made his changes. You might consider installing the versions of Arduino and Teensyduino that were available back then, and see if it works with those tools and an unmodified copy of aJSON.


#9

Also, you say you have a version 3 SmartMatrix board, but version 3 won’t (easily) fit a Teensy 3.5. Do you actually have a V4 board? If you have a V4, Jason’s sketch is configured to run on it. If you have V3, you’ll need to open hardware.h and remove the #include that’s in there, as it configures the SmartMatrix Library to use a V4 board.


#10

Hey Louis… Thanks for looking into it…, ive got copies of the ajson and modified gif player i will try again later and let you know how i get on…i did try the gifplayer before when trying to fix the issue in november. The sdcard crash problem i had when i i was running a very minimal version of the 64x64 on the teensy 3.2… so i have a few of the patterns setup on the teensy 3.2 and on the 3.5 i have your gifplayer, and swap between the 2… ( a bit long winded i know)

i did look into upgrading to v4, but when i last looked it was out of stock. i still have about four V3 sitting around so thought i would try and get away with using them. i will see how i get on and if needed will grab a few V4 boards…

thanks again


#11

Yep, V3 and V4 were out of stock for many months, but there are plenty of V4 in stock now. V4 saves a few pins and DMA channels by adding an external latch, and it’s easy to add a Teensy 3.5/3.6 and remove it as well, but If you got a Teensy 3.5 working with V3, good for you!


#12

Hey Loius… after changing the libraries you mentioned, i had only one other error which was the ir remote. i was getting lots of errors regarding timings. after updating / changing the irremote i managed to compile.

Everything is working. , patterns and sound, clock etc… the only issue is with gifs…, it wont boot with a sdcard installed. either using onboard or smartmatrix version 3 onboard…, so setting onboard or pin 15… both crash the teensy 3.5… so looking good so far…if that side could be fixed, that would be brilliant… i fired up my old 32x32 smarmatrix…, its like looking an old crt screen compared to a 4k screen lol… loving the changes jason has made


#13

ok… after playing around with it for a while… i have noticed one other issue…, when running with the standard menu screen… pattern, settings etcs scrolling everything is fine… or if i have it with just the pattern playing… when i place the clock on, which is one of the reason i use it… all the pattens slow or freeze… playback drops to about 50% on some, but spiro stops on the frame its on and repeats it over and over… if i remove the clock it resumes normal playback…


#14

I was able to fix the crash with SD card installed on a Teensy 3.5. In Aurora.ino code seems to halt at line 422: menuItemAnimations.visible = sdAvailable && animations.imageCount > 0;

Commenting this out seems to fix the issue and thus far I’ve not had issues with it properly identifying gif’s.

I have a 32x32 panel and had scaling issues. I was able to fix this by changing lines 279 and 280 to:
int16_t nx = x;
int16_t ny = y;


#15

Finally !!! … I am running the teensy 3.5 on an old version 3 smartmatrix board. using 2 64x32 boards.

And it works at last, i have all animations, vu meters and now animated gifs.

Ok… Now this i do not understand !! Louis you have a great piece of kit here., Along with Jason`S Aurora on a 64x64 matrix looks amazing. There is nothing out that comes close to it. YET… it seems to have been left to fade away. I was looking through old posts to revisit this again after Techy101 post and it seems alot of jasons posts had been removed !!!

I run a youtube page, I have posted a few times the smartmatrix setup, using the origianal 32x32 setup and the 64x64… i get alot of comments about it… why do guys not push this further ?


#16

@techy101 Thanks for posting this fix!

@mannymiller1 Are you Cine-Lights on Youtube? Didn’t know that, I like your channel!

I guess the short answer is Aurora is just one of many side projects that Jason has, and if you’ve seen his social media and portfolio site, he has a lot of other cool stuff to work on. The SmartMatrix Library and Shield is also only one of my side projects. I would love to get Aurora refreshed and ready to run on SmartLED Shield V4 with a Teensy 3.5/3.6, and will try to dedicate some time to get that going at some point (unfortunately not soon). I’d also love to get Aurora running on a platform with WiFi, e.g. ESP8266/ESP32, and have some ideas on how to make that work, but now we’re talking aspirational long term plans. In the meantime, thanks to the project being open source and awesome people like you and Techy101, Aurora lives on until we find more time to continue the project.

I was looking through old posts to revisit this again after Techy101 post and it seems alot of jasons posts had been removed !!!

That doesn’t sound right, do you have any examples? I don’t think Jason or I have been deleting any posts.


#17

Old thread I just noticed, but


works fine on any CPU and backend supported by SmartMatrix or FastLED::NeoMatrix.
I removed all the CPU specific stuff and extracted the demos.
They work on other resolutions of course, I’ve used them on displays from 24x32 to 64x96

Now, if someone with the original Aurora can look at https://github.com/marcmerlin/FastLED_NeoMatrix_SmartMatrix_LEDMatrix_GFX_Demos/tree/master/GFX/Aurora/_baddisplay and help me debug those demos to see if I ported them wrong.

https://github.com/marcmerlin/FastLED_NeoMatrix_SmartMatrix_LEDMatrix_GFX_Demos/tree/master/GFX/Aurora/_notmytaste also don’t look so good and it might be my fault. Hard to make sure given that I’ve never seen them work in their original way.

@mannymiller1 do you mind having a look and sending PRs if applicable?


#18

Hi, would love to have a look. at this time i am using the old smartmatrix board fitted with a teensy 3.5, and its working a treat… animated gif, patterns, and sound animations all working. i have stripped out a few which even though Jason has fixed them, they didnt seem to work 100%.

i also just got the new version 4 board which i havent used yet. if i could get a full working aurora setup working on 64x64, then i will use it and make it more perminant.


#19

Hi Louis, sorry i didnt see your post from december.

Yes i am cine-lights, its just a little side hobby… making bits and learning, and sharing as i do… I have posted quite a few reviews on the smartmatrix, and have another one lined up covering the new version 4 board. which ive finally managed to get my hands on. as mentioned in another post on this post, i do have a working Aurora on my 64x64 matrix, with everything working using the older board though with a teensy 3.5. it still has a few issues. , when selecting time, overlaying some of the patterns it slows right up. but i tend to have the time on overlaying animated gifs. it looks great. still one of my favourite setups of all time…